{"answers":{"affected":"3 open source packages ship an affected version, including pwntools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-28468 in the wild and no public exploit code.","fix":"Upgrade pwntools to 4.3.1 or later.","what":"CVE-2020-28468 is a high-severity code injection vulnerability in pwntools, published on 8 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-28468 and fix it if it is affected.\n\nWhat it is: CVE-2020-28468 is a high-severity code injection vulnerability in pwntools, published on 8 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-28468 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pwntools (PyPI): affected all versions; fixed in 4.3.1\n- pwntools (PyPI): affected all versions; fixed in 4.3.1\n- pwntools (PyPI): affected all versions; fixed in 4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-28468/ (Markdown: https://insights.sbomify.com/CVE-2020-28468/index.md)","id":"CVE-2020-28468","markdown":"https://insights.sbomify.com/CVE-2020-28468/index.md","name":"CVE-2020-28468","record":{"aliases":["GHSA-7xc5-ggpp-g249","PYSEC-2021-72","SNYK-PYTHON-PWNTOOLS-1047345"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python exploitation library","requires_auth":"none","summary":"Attackers can execute arbitrary code via Server-Side Template Injection in the shellcraft generator of the pwntools library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"pwntools","vendor":"pwntools_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Control of Generation of Code ('Code Injection')","id":"CVE-2020-28468","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":3,"n_references":3,"next":{"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2020-28469"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"pwntools","purl":null,"source":"GHSA-7xc5-ggpp-g249"},{"ecosystem":"PyPI","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"pwntools","purl":"pkg:pypi/pwntools","source":"GHSA-7xc5-ggpp-g249"},{"ecosystem":"PyPI","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"pwntools","purl":"pkg:pypi/pwntools","source":"PYSEC-2021-72"}],"prev":{"headline":"Denial of Service (DoS)","id":"CVE-2020-28466"},"products":["pwntools"],"published":"2021-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via Server-Side Template Injection in the shellcraft generator of the pwntools library.","url":"https://insights.sbomify.com/CVE-2020-28468/"}