# CVE-2020-28468: Improper Control of Generation of Code ('Code Injection')

> Attackers can execute arbitrary code via Server-Side Template Injection in the shellcraft generator of the pwntools library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7xc5-ggpp-g249, PYSEC-2021-72, SNYK-PYTHON-PWNTOOLS-1047345

## What is CVE-2020-28468?

CVE-2020-28468 is a high-severity code injection vulnerability in pwntools, published on 8 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-28468?

3 open source packages ship an affected version, including pwntools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pwntools` | PyPI | All versions | 4.3.1 |
| `pwntools` | PyPI | All versions | 4.3.1 |
| `pwntools` | PyPI | All versions | 4.3.1 |

Products: Pwntools Project Pwntools.

## How do I fix CVE-2020-28468?

Upgrade pwntools to 4.3.1 or later.

## Is CVE-2020-28468 being exploited?

There is no known exploitation of CVE-2020-28468 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28468 and fix it if it is affected.

What it is: CVE-2020-28468 is a high-severity code injection vulnerability in pwntools, published on 8 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28468 in the wild and no public exploit code.

Affected packages and fixed versions:
- pwntools (PyPI): affected all versions; fixed in 4.3.1
- pwntools (PyPI): affected all versions; fixed in 4.3.1
- pwntools (PyPI): affected all versions; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28468/ (Markdown: https://insights.sbomify.com/CVE-2020-28468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28468
- OSV: https://osv.dev/vulnerability/CVE-2020-28468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28468/
Summaries are generated and may contain mistakes; the official description above is the record.
