# CVE-2020-28469: Regular Expression Denial of Service (ReDoS)

> An attacker can cause a denial of service in applications using the glob-parent library by providing specially crafted input that triggers excessive regex processing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2021
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-44118, AZL-44862, BIT-gulp-2020-28469, DEBIAN-CVE-2020-28469, GHSA-ww39-953v-wcq6, ROOT-APP-NPM-CVE-2020-28469

## What is CVE-2020-28469?

CVE-2020-28469 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 3 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package glob-parent before 5.1.2. The enclosure regex used to check for strings ending in enclosure containing path separator.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-28469?

3 open source packages ship an affected version, including glob-parent and gulp. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glob-parent` | npm | From 4.0.0 | 5.1.2 |
| `glob-parent` | npm | From 4.0.0 | 5.1.2 |
| `gulp` | Bitnami | All versions | 5.1.2 |

Products: Gulpjs Glob-Parent, Oracle Communications Cloud Native Core Policy.

## How do I fix CVE-2020-28469?

Upgrade glob-parent to 5.1.2 or later.

## Is CVE-2020-28469 being exploited?

There is no known exploitation of CVE-2020-28469 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Cloud Native Core Policy

- [CVE-2021-35065](https://insights.sbomify.com/CVE-2021-35065/): glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28469 and fix it if it is affected.

What it is: CVE-2020-28469 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 3 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28469 in the wild and no public exploit code.

Affected packages and fixed versions:
- glob-parent (npm): affected from 4.0.0; fixed in 5.1.2
- glob-parent (npm): affected from 4.0.0; fixed in 5.1.2
- gulp (Bitnami): affected all versions; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28469/ (Markdown: https://insights.sbomify.com/CVE-2020-28469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28469
- OSV: https://osv.dev/vulnerability/CVE-2020-28469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28469/
Summaries are generated and may contain mistakes; the official description above is the record.
