# CVE-2020-28472: Prototype Pollution

> Attackers can pollute the application prototype via malicious INI files, potentially leading to code execution or privilege escalation in applications using the AWS SDK.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2021
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1771891824, GHSA-rrc9-gqf8-8rwg

## What is CVE-2020-28472?

CVE-2020-28472 is a high-severity vulnerability in @aws-sdk/shared-ini-file-loader, published on 19 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package @aws-sdk/shared-ini-file-loader before 1.0.0-rc.9; the package aws-sdk before 2.814.0. If an attacker submits a malicious INI file to an application that parses it with loadSharedConfigFiles , they will pollute the prototype on the application. This can be exploited further depending on the context.

## Which versions are affected by CVE-2020-28472?

4 open source packages ship an affected version, including @aws-sdk/shared-ini-file-loader and aws-sdk. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@aws-sdk/shared-ini-file-loader` | npm | All versions | 1.0.0-rc.9 |
| `@aws-sdk/shared-ini-file-loader` | npm | All versions | 1.0.0-rc.9 |
| `aws-sdk` | npm | All versions | 2.814.0 |
| `aws-sdk` | npm | All versions | 2.814.0 |

Products: Amazon Aws Sdk for Javascipt, Amazon Aws Shared Configuration File Loader.

## How do I fix CVE-2020-28472?

Upgrade @aws-sdk/shared-ini-file-loader to 1.0.0-rc.9 or later.

## Is CVE-2020-28472 being exploited?

There is no known exploitation of CVE-2020-28472 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28472 and fix it if it is affected.

What it is: CVE-2020-28472 is a high-severity vulnerability in @aws-sdk/shared-ini-file-loader, published on 19 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28472 in the wild and no public exploit code.

Affected packages and fixed versions:
- @aws-sdk/shared-ini-file-loader (npm): affected all versions; fixed in 1.0.0-rc.9
- @aws-sdk/shared-ini-file-loader (npm): affected all versions; fixed in 1.0.0-rc.9
- aws-sdk (npm): affected all versions; fixed in 2.814.0
- aws-sdk (npm): affected all versions; fixed in 2.814.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28472/ (Markdown: https://insights.sbomify.com/CVE-2020-28472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28472
- OSV: https://osv.dev/vulnerability/CVE-2020-28472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28472/
Summaries are generated and may contain mistakes; the official description above is the record.
