# CVE-2020-28487: Cross-site Scripting (XSS)

> An attacker controlling timeline items can inject malicious scripts, leading to code execution in the context of the application using vis-timeline.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-9mrv-456v-pf22

## What is CVE-2020-28487?

CVE-2020-28487 is a medium-severity cross-site scripting vulnerability in vis-timeline, published on 22 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

This affects the package vis-timeline before 7.4.4. An attacker with the ability to control the items of a Timeline element can inject additional script code into the generated application.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-28487?

2 open source packages ship an affected version, including vis-timeline. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vis-timeline` | npm | All versions | 7.4.4 |
| `vis-timeline` | npm | All versions | 7.4.4 |

Products: Visjs Vis-Timeline.

## How do I fix CVE-2020-28487?

Upgrade vis-timeline to 7.4.4 or later.

## Is CVE-2020-28487 being exploited?

There is no known exploitation of CVE-2020-28487 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28487 and fix it if it is affected.

What it is: CVE-2020-28487 is a medium-severity cross-site scripting vulnerability in vis-timeline, published on 22 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-28487 in the wild and no public exploit code.

Affected packages and fixed versions:
- vis-timeline (npm): affected all versions; fixed in 7.4.4
- vis-timeline (npm): affected all versions; fixed in 7.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28487/ (Markdown: https://insights.sbomify.com/CVE-2020-28487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28487
- OSV: https://osv.dev/vulnerability/CVE-2020-28487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28487/
Summaries are generated and may contain mistakes; the official description above is the record.
