# CVE-2020-28500: Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service in applications using Lodash by exploiting inefficient regular expressions in string manipulation functions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2021
- **Updated:** 8 Oct 2026
- **Also known as:** AZL-44085, DEBIAN-CVE-2020-28500, GHSA-29mw-wpgm-hmr9, ROOT-APP-NPM-CVE-2020-28500, UBUNTU-CVE-2020-28500

## What is CVE-2020-28500?

CVE-2020-28500 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lodash versions prior to 4.17.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the toNumber, trim and trimEnd functions.

## Which versions are affected by CVE-2020-28500?

10 open source packages ship an affected version, including lodash-rails, lodash and lodash-es. It affects 19 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lodash-rails` | RubyGems | From 4.0.0 | 4.17.21 |
| `lodash-rails` | RubyGems | From 4.0.0 | 4.17.21 |
| `lodash` | npm | From 4.0.0 | 4.17.21 |
| `lodash` | npm | From 4.0.0 | 4.17.21 |
| `lodash-es` | npm | From 4.0.0 | 4.17.21 |
| `lodash-es` | npm | From 4.0.0 | 4.17.21 |
| `lodash.trim` | npm | From 4.0.0 to 4.5.1 | None |
| `lodash.trim` | npm | From 4.0.0 to 4.5.1 | None |
| `lodash.trimend` | npm | From 4.0.0 to 4.5.1 | None |
| `lodash.trimend` | npm | From 4.0.0 to 4.5.1 | None |

Products: Lodash Lodash, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Extensibility Workbench, Oracle Banking Supply Chain Finance, Oracle Banking Trade Finance Process Management, Oracle Communications Cloud Native Core Policy, Oracle Communications Design Studio, Oracle Communications Services Gatekeeper, Oracle Communications Session Border Controller, Oracle Enterprise Communications Broker, Oracle Financial Services Crime and Compliance Management Studio, Oracle Health Sciences Data Management Workbench, Oracle Jd Edwards Enterpriseone Tools, Oracle Peoplesoft Enterprise Peopletools, Oracle Primavera Gateway, Oracle Primavera Unifier, Oracle Retail Customer Management and Segmentation Foundation, Siemens Sinec Ins.

## How do I fix CVE-2020-28500?

Upgrade lodash-rails to 4.17.21 or later.

## Is CVE-2020-28500 being exploited?

There is no known exploitation of CVE-2020-28500 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Cloud Native Core Policy

- [CVE-2026-4800](https://insights.sbomify.com/CVE-2026-4800/): lodash vulnerable to Code Injection via `_.template` imports key names (high 8.1)
- [CVE-2020-8203](https://insights.sbomify.com/CVE-2020-8203/): Prototype Pollution in lodash (high 7.4)
- [CVE-2021-23337](https://insights.sbomify.com/CVE-2021-23337/): Command Injection (high 7.2)
- [CVE-2025-13465](https://insights.sbomify.com/CVE-2025-13465/): Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions (medium 6.9)
- [CVE-2026-2950](https://insights.sbomify.com/CVE-2026-2950/): lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit` (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28500 and fix it if it is affected.

What it is: CVE-2020-28500 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28500 in the wild and no public exploit code.

Affected packages and fixed versions:
- lodash-rails (RubyGems): affected from 4.0.0; fixed in 4.17.21
- lodash-rails (RubyGems): affected from 4.0.0; fixed in 4.17.21
- lodash (npm): affected from 4.0.0; fixed in 4.17.21
- lodash (npm): affected from 4.0.0; fixed in 4.17.21
- lodash-es (npm): affected from 4.0.0; fixed in 4.17.21
- lodash-es (npm): affected from 4.0.0; fixed in 4.17.21
- lodash.trim (npm): affected from 4.0.0 up to 4.5.1; no fix listed
- lodash.trim (npm): affected from 4.0.0 up to 4.5.1; no fix listed
- lodash.trimend (npm): affected from 4.0.0 up to 4.5.1; no fix listed
- lodash.trimend (npm): affected from 4.0.0 up to 4.5.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28500/ (Markdown: https://insights.sbomify.com/CVE-2020-28500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28500
- OSV: https://osv.dev/vulnerability/CVE-2020-28500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28500/
Summaries are generated and may contain mistakes; the official description above is the record.
