# CVE-2020-28502: Arbitrary Code Injection

> Attackers can execute arbitrary code via malicious input in synchronous requests using vulnerable Node.js HTTP libraries.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1777336760, DEBIAN-CVE-2020-28502, GHSA-h4j5-c7cj-74xg, UBUNTU-CVE-2020-28502

## What is CVE-2020-28502?

CVE-2020-28502 is a high-severity code injection vulnerability in xmlhttprequest, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package xmlhttprequest before 1.7.0; all versions of package xmlhttprequest-ssl. Provided requests are sent synchronously (async=False on xhr.open), malicious user input flowing into xhr.send could result in arbitrary code being injected and run.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-28502?

4 open source packages ship an affected version, including xmlhttprequest and xmlhttprequest-ssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xmlhttprequest` | npm | All versions | 1.7.0 |
| `xmlhttprequest` | npm | All versions | 1.7.0 |
| `xmlhttprequest-ssl` | npm | All versions | 1.6.2 |
| `xmlhttprequest-ssl` | npm | All versions | 1.6.2 |

Products: Xmlhttprequest Project Xmlhttprequest.

## How do I fix CVE-2020-28502?

Upgrade xmlhttprequest to 1.7.0 or later.

## Is CVE-2020-28502 being exploited?

There is no known exploitation of CVE-2020-28502 in the wild and no public exploit code.

Public exploit code:

- CVE-2020-28502 node-XMLHttpRequest RCE (github_poc): https://github.com/s-index/CVE-2020-28502
- https://github.com/dpredrag/CVE-2020-28502 (github_poc): https://github.com/dpredrag/CVE-2020-28502

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28502 and fix it if it is affected.

What it is: CVE-2020-28502 is a high-severity code injection vulnerability in xmlhttprequest, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28502 in the wild and no public exploit code.

Affected packages and fixed versions:
- xmlhttprequest (npm): affected all versions; fixed in 1.7.0
- xmlhttprequest (npm): affected all versions; fixed in 1.7.0
- xmlhttprequest-ssl (npm): affected all versions; fixed in 1.6.2
- xmlhttprequest-ssl (npm): affected all versions; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28502/ (Markdown: https://insights.sbomify.com/CVE-2020-28502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28502
- OSV: https://osv.dev/vulnerability/CVE-2020-28502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28502/
Summaries are generated and may contain mistakes; the official description above is the record.
