# CVE-2020-28735: SSRF attacks via tracebacks in Plone

> Attackers with Manager role can exploit the tracebacks feature to perform Server-Side Request Forgery attacks in Plone.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x7wf-5mjc-6x76, PYSEC-2020-247, PYSEC-2026-2881, PYSEC-2026-2884, PYSEC-2026-2887, PYSEC-2026-737

## What is CVE-2020-28735?

CVE-2020-28735 is a high-severity server-side request forgery vulnerability in Plone Plone, published on 30 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Plone before 5.2.3 allows SSRF attacks via the tracebacks feature (only available to the Manager role).

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-28735?

15 open source packages ship an affected version, including plone, Plone and plone-app-dexterity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | 5.2.3 |
| `plone` | PyPI | All versions | 5.2.3 |
| `Plone` | PyPI | All versions | 5.2.3 |
| `plone-app-dexterity` | PyPI | All versions | 2.6.8 |
| `plone-app-dexterity` | PyPI | All versions | 2.6.8 |
| `plone-app-event` | PyPI | All versions | 3.2.10 |
| `plone-app-event` | PyPI | All versions | 3.2.10 |
| `plone-app-theming` | PyPI | All versions | 4.1.6 |
| `plone-app-theming` | PyPI | All versions | 4.1.6 |
| `plone-supermodel` | PyPI | All versions | 1.6.3 |
| `plone-supermodel` | PyPI | All versions | 1.6.3 |
| `plone.app.dexterity` | PyPI | All versions | 2.6.8 |
| `plone.app.event` | PyPI | All versions | 3.2.10 |
| `plone.app.theming` | PyPI | All versions | 4.1.6 |
| `plone.supermodel` | PyPI | All versions | 1.6.3 |

Products: Plone Plone.

## How do I fix CVE-2020-28735?

Upgrade plone to 5.2.3 or later.

## Is CVE-2020-28735 being exploited?

There is no known exploitation of CVE-2020-28735 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28735 and fix it if it is affected.

What it is: CVE-2020-28735 is a high-severity server-side request forgery vulnerability in Plone Plone, published on 30 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28735 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; fixed in 5.2.3
- plone (PyPI): affected all versions; fixed in 5.2.3
- Plone (PyPI): affected all versions; fixed in 5.2.3
- plone-app-dexterity (PyPI): affected all versions; fixed in 2.6.8
- plone-app-dexterity (PyPI): affected all versions; fixed in 2.6.8
- plone-app-event (PyPI): affected all versions; fixed in 3.2.10
- plone-app-event (PyPI): affected all versions; fixed in 3.2.10
- plone-app-theming (PyPI): affected all versions; fixed in 4.1.6
- plone-app-theming (PyPI): affected all versions; fixed in 4.1.6
- plone-supermodel (PyPI): affected all versions; fixed in 1.6.3
- plone-supermodel (PyPI): affected all versions; fixed in 1.6.3
- plone.app.dexterity (PyPI): affected all versions; fixed in 2.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28735/ (Markdown: https://insights.sbomify.com/CVE-2020-28735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28735
- OSV: https://osv.dev/vulnerability/CVE-2020-28735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28735/
Summaries are generated and may contain mistakes; the official description above is the record.
