# CVE-2020-28912: Missing authorization in n/a

> An unprivileged local user can intercept named pipe connections to MariaDB on Windows, reading data and executing SQL commands as the connected user.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-28912, BIT-mariadb-2020-28912, BIT-mariadb-min-2020-28912, BIT-mysql-client-2020-28912, GHSA-3mpv-3cfr-mgjj

## What is CVE-2020-28912?

CVE-2020-28912 is a high-severity missing authorization vulnerability in Mariadb Mariadb, published on 24 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

With MariaDB running on Windows, when local clients connect to the server over named pipes, it's possible for an unprivileged user with an ability to run code on the server machine to intercept the named pipe connection and act as a man-in-the-middle, gaining access to all the data passed between the client and the server, and getting the ability to run SQL commands on behalf of the connected user. This occurs because of an incorrect security descriptor. This affects MariaDB Server before 10.1.48, 10.2.x before 10.2.35, 10.3.x before 10.3.26, 10.4.x before 10.4.16, and 10.5.x before 10.5.7. NOTE: this issue exists because certain details of the MariaDB CVE-2019-2503 fix did not comprehensively address attack variants against MariaDB. This situation is specific to MariaDB, and thus CVE-2020-28912 does NOT apply to other vendors that were originally affected by CVE-2019-2503.

## Which versions are affected by CVE-2020-28912?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
| `mariadb-min` | Bitnami | All versions | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
| `mysql-client` | Bitnami | All versions | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |

Products: Mariadb Mariadb.

## How do I fix CVE-2020-28912?

Upgrade mariadb to a fixed version for your release line: 10.1.48, 10.2.35, 10.3.26 or 10.4.16.

## Is CVE-2020-28912 being exploited?

There is no known exploitation of CVE-2020-28912 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28912 and fix it if it is affected.

What it is: CVE-2020-28912 is a high-severity missing authorization vulnerability in Mariadb Mariadb, published on 24 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28912 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7
- mariadb-min (Bitnami): affected all versions; fixed in 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7
- mysql-client (Bitnami): affected all versions; fixed in 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28912/ (Markdown: https://insights.sbomify.com/CVE-2020-28912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28912
- OSV: https://osv.dev/vulnerability/CVE-2020-28912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28912/
Summaries are generated and may contain mistakes; the official description above is the record.
