# CVE-2020-28924: Use of Cryptographically Weak Pseudo-Random Number Generator in Rclone

> Weak random number generation in Rclone produces low-entropy passwords, allowing attackers to decrypt encrypted data via dictionary attacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-rclone-2020-28924, DEBIAN-CVE-2020-28924, GHSA-rmw5-xpg9-jr29, GO-2022-0878, JLSEC-2026-278, openSUSE-SU-2020:2008-1, openSUSE-SU-2020:2035-1, openSUSE-SU-2020:2168-1, openSUSE-SU-2021:0272-1, openSUSE-SU-2024:11297-1

## What is CVE-2020-28924?

CVE-2020-28924 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Rclone before 1.53.3. Due to the use of a weak random number generator, the password generator has been producing weak passwords with much less entropy than advertised. The suggested passwords depend deterministically on the time the second rclone was started. This limits the entropy of the passwords enormously. These passwords are often used in the crypt backend for encryption of data. It would be possible to make a dictionary of all possible passwords with about 38 million entries per password length. This would make decryption of secret material possible with a plausible amount of effort. NOTE: all passwords generated by affected versions should be changed.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)), CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2020-28924?

4 open source packages ship an affected version, including github.com/rclone/rclone and rclone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rclone/rclone` | Go | All versions | 1.53.3 |
| `github.com/rclone/rclone` | Go | All versions | 1.53.3 |
| `github.com/rclone/rclone` | Go | All versions | 1.53.3 |
| `rclone` | Bitnami | All versions | 1.53.3 |
| `rclone` | SUSE:Package Hub 15 SP1 | All versions | 1.53.3-bp151.4.6.1 |
| `rclone` | SUSE:Package Hub 15 SP2 | All versions | 1.53.3-bp152.2.4.11 |
| `rclone` | openSUSE:Leap 15.1 | All versions | 1.53.3-lp151.3.6.1 |
| `rclone` | openSUSE:Leap 15.2 | All versions | 1.53.3-lp152.2.3.1 |
| `rclone` | openSUSE:Tumbleweed | All versions | 1.55.1-1.3 |

Products: Fedoraproject Fedora, Rclone Rclone.

## How do I fix CVE-2020-28924?

Upgrade github.com/rclone/rclone to 1.53.3 or later.

## Is CVE-2020-28924 being exploited?

There is no known exploitation of CVE-2020-28924 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28924 and fix it if it is affected.

What it is: CVE-2020-28924 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28924 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rclone/rclone (Go): affected all versions; fixed in 1.53.3
- github.com/rclone/rclone (Go): affected all versions; fixed in 1.53.3
- github.com/rclone/rclone (Go): affected all versions; fixed in 1.53.3
- rclone (Bitnami): affected all versions; fixed in 1.53.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28924/ (Markdown: https://insights.sbomify.com/CVE-2020-28924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28924
- OSV: https://osv.dev/vulnerability/CVE-2020-28924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28924/
Summaries are generated and may contain mistakes; the official description above is the record.
