# CVE-2020-28972: SaltStack Salt Improper Certificate Validation

> SaltStack fails to validate SSL/TLS certificates for VMware connections, allowing attackers to bypass security checks and potentially intercept traffic.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w589-r335-4f55, PYSEC-2021-74, UBUNTU-CVE-2020-28972

## What is CVE-2020-28972?

CVE-2020-28972 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In SaltStack Salt before 3002.5, authentication to VMware vcenter, vsphere, and esxi servers (in the vmware.py files) does not always validate the SSL/TLS certificate.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-28972?

19 open source packages ship an affected version, including salt. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 2015.8.10, 2015.8.13, 2016.3.4, 2016.3.6, 2016.3.8, 2016.11.3, 2016.11.5, 2016.11.10, 2017.7.8, 2019.2.0rc1, 2019.2.5, 2019.2.8, 3000.6, 3001.4, 3002.5 |
| `salt` | PyPI | All versions | 2015.8.13 |
| `salt` | PyPI | All versions | 2015.8.13 |
| `salt` | PyPI | From 2016.11.7 | 2016.11.10 |
| `salt` | PyPI | From 2016.11.7 | 2016.11.10 |
| `salt` | PyPI | From 2016.3.0 | 2016.11.5 |
| `salt` | PyPI | From 2016.3.0 | 2016.11.5 |
| `salt` | PyPI | From 2017.5.0 | 2017.7.8 |
| `salt` | PyPI | From 2017.5.0 | 2017.7.8 |
| `salt` | PyPI | From 2018.2.0 to 2018.3.5 | None |
| `salt` | PyPI | From 2018.2.0 to 2018.3.5 | None |
| `salt` | PyPI | From 2019.2.0 | 2019.2.8 |
| `salt` | PyPI | From 2019.2.0 | 2019.2.8 |
| `salt` | PyPI | From 3000 | 3000.7 |
| `salt` | PyPI | From 3000 | 3000.7 |
| `salt` | PyPI | From 3001 | 3001.5 |
| `salt` | PyPI | From 3001 | 3001.5 |
| `salt` | PyPI | From 3002 | 3002.3 |
| `salt` | PyPI | From 3002 | 3002.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Saltstack Salt.

## How do I fix CVE-2020-28972?

Upgrade salt to a fixed version for your release line: 2015.8.10, 2015.8.13, 2016.3.4 or 2016.3.6.

## Is CVE-2020-28972 being exploited?

There is no known exploitation of CVE-2020-28972 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28972 and fix it if it is affected.

What it is: CVE-2020-28972 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28972 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 2015.8.10, 2015.8.13, 2016.3.4, 2016.3.6, 2016.3.8, 2016.11.3, 2016.11.5, 2016.11.10, 2017.7.8, 2019.2.0rc1, 2019.2.5, 2019.2.8, 3000.6, 3001.4, 3002.5
- salt (PyPI): affected all versions; fixed in 2015.8.13
- salt (PyPI): affected all versions; fixed in 2015.8.13
- salt (PyPI): affected from 2016.11.7; fixed in 2016.11.10
- salt (PyPI): affected from 2016.11.7; fixed in 2016.11.10
- salt (PyPI): affected from 2016.3.0; fixed in 2016.11.5
- salt (PyPI): affected from 2016.3.0; fixed in 2016.11.5
- salt (PyPI): affected from 2017.5.0; fixed in 2017.7.8
- salt (PyPI): affected from 2017.5.0; fixed in 2017.7.8
- salt (PyPI): affected from 2018.2.0 up to 2018.3.5; no fix listed
- salt (PyPI): affected from 2018.2.0 up to 2018.3.5; no fix listed
- salt (PyPI): affected from 2019.2.0; fixed in 2019.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28972/ (Markdown: https://insights.sbomify.com/CVE-2020-28972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28972
- OSV: https://osv.dev/vulnerability/CVE-2020-28972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28972/
Summaries are generated and may contain mistakes; the official description above is the record.
