{"answers":{"affected":"1 open source package ship an affected version, including mediawiki. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-29003 in the wild and no public exploit code.","fix":"Upgrade mediawiki to 1.35.1 or later.","what":"CVE-2020-29003 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 24 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-29003 and fix it if it is affected.\n\nWhat it is: CVE-2020-29003 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 24 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-29003 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.35.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-29003/ (Markdown: https://insights.sbomify.com/CVE-2020-29003/index.md)","id":"CVE-2020-29003","markdown":"https://insights.sbomify.com/CVE-2020-29003/index.md","name":"CVE-2020-29003","record":{"aliases":["BIT-mediawiki-2020-29003","GHSA-6f9q-3x2v-r6cg","UBUNTU-CVE-2020-29003"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki PollNY extension","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via poll answer options in the MediaWiki PollNY extension, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The PollNY extension for MediaWiki through 1.35 allows XSS via an answer option for a poll question, entered during Special:CreatePoll or Special:UpdatePoll.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2020-29003","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mediawiki:mediawiki","products":["mediawiki:mediawiki"],"type":"xss","year":"2020"},"n_packages":1,"n_references":1,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2020-29004"},"packages":[{"ecosystem":"Bitnami","fixed":["1.35.1"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2020-29003"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-29002"},"products":["n/a"],"published":"2020-11-24","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2023-37303","kev_date_added":null,"published":"2023-06-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-29904","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-29906","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2022-28205","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28206","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28209","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2021-36126","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via poll answer options in the MediaWiki PollNY extension, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2020-29003/"}