{"answers":{"affected":"5 open source packages ship an affected version, including petl. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-29128 in the wild and no public exploit code.","fix":"Upgrade petl to 1.6.8 or later.","what":"CVE-2020-29128 is a critical vulnerability in n/a, published on 26 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-29128 and fix it if it is affected.\n\nWhat it is: CVE-2020-29128 is a critical vulnerability in n/a, published on 26 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-29128 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- petl (PyPI): affected all versions; fixed in 1.6.8\n- petl (PyPI): affected all versions; fixed in 1.6.8\n- petl (PyPI): affected all versions; fixed in 1.6.8\n- petl (PyPI): affected all versions; fixed in 1.6.8\n- petl (PyPI): affected all versions; fixed in 1.6.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-29128/ (Markdown: https://insights.sbomify.com/CVE-2020-29128/index.md)","id":"CVE-2020-29128","markdown":"https://insights.sbomify.com/CVE-2020-29128/index.md","name":"CVE-2020-29128","record":{"aliases":["GHSA-69q2-p9xp-739v","GHSA-f5gc-p5m3-v347","PYSEC-2020-75"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Python ETL library","requires_auth":"none","summary":"An attacker can exploit XML entity resolution in the petl library to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"petl","vendor":"petl_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-91","name":"XML Injection"}],"description":"petl before 1.68, in some configurations, allows resolution of entities in an XML document.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Duplicate Advisory: XML Injection in petl","id":"CVE-2020-29128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":5,"n_references":7,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-29129"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.8"],"introduced":["0"],"last_affected":[],"package":"petl","purl":null,"source":"GHSA-69q2-p9xp-739v"},{"ecosystem":"PyPI","fixed":["1.6.8"],"introduced":["0"],"last_affected":[],"package":"petl","purl":"pkg:pypi/petl","source":"GHSA-69q2-p9xp-739v"},{"ecosystem":"PyPI","fixed":["1.6.8"],"introduced":["0"],"last_affected":[],"package":"petl","purl":null,"source":"GHSA-f5gc-p5m3-v347"},{"ecosystem":"PyPI","fixed":["1.6.8"],"introduced":["0"],"last_affected":[],"package":"petl","purl":"pkg:pypi/petl","source":"GHSA-f5gc-p5m3-v347"},{"ecosystem":"PyPI","fixed":["1.6.8"],"introduced":["0"],"last_affected":[],"package":"petl","purl":"pkg:pypi/petl","source":"PYSEC-2020-75"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2020-29127"},"products":["n/a"],"published":"2020-11-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can exploit XML entity resolution in the petl library to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2020-29128/"}