# CVE-2020-29128: Duplicate Advisory: XML Injection in petl

> An attacker can exploit XML entity resolution in the petl library to read sensitive files or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-69q2-p9xp-739v, GHSA-f5gc-p5m3-v347, PYSEC-2020-75

## What is CVE-2020-29128?

CVE-2020-29128 is a critical vulnerability in n/a, published on 26 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

petl before 1.68, in some configurations, allows resolution of entities in an XML document.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2020-29128?

5 open source packages ship an affected version, including petl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `petl` | PyPI | All versions | 1.6.8 |
| `petl` | PyPI | All versions | 1.6.8 |
| `petl` | PyPI | All versions | 1.6.8 |
| `petl` | PyPI | All versions | 1.6.8 |
| `petl` | PyPI | All versions | 1.6.8 |

Products: Petl Project Petl.

## How do I fix CVE-2020-29128?

Upgrade petl to 1.6.8 or later.

## Is CVE-2020-29128 being exploited?

There is no known exploitation of CVE-2020-29128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29128 and fix it if it is affected.

What it is: CVE-2020-29128 is a critical vulnerability in n/a, published on 26 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-29128 in the wild and no public exploit code.

Affected packages and fixed versions:
- petl (PyPI): affected all versions; fixed in 1.6.8
- petl (PyPI): affected all versions; fixed in 1.6.8
- petl (PyPI): affected all versions; fixed in 1.6.8
- petl (PyPI): affected all versions; fixed in 1.6.8
- petl (PyPI): affected all versions; fixed in 1.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29128/ (Markdown: https://insights.sbomify.com/CVE-2020-29128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29128
- OSV: https://osv.dev/vulnerability/CVE-2020-29128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29128/
Summaries are generated and may contain mistakes; the official description above is the record.
