{"answers":{"affected":"2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-29156 in the wild and no public exploit code.","fix":"Upgrade woocommerce/woocommerce to 4.7.0 or later.","what":"CVE-2020-29156 is a medium-severity missing authorization vulnerability in n/a, published on 27 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-29156 and fix it if it is affected.\n\nWhat it is: CVE-2020-29156 is a medium-severity missing authorization vulnerability in n/a, published on 27 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-29156 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 4.7.0\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 4.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-29156/ (Markdown: https://insights.sbomify.com/CVE-2020-29156/index.md)","id":"CVE-2020-29156","markdown":"https://insights.sbomify.com/CVE-2020-29156/index.md","name":"CVE-2020-29156","record":{"aliases":["GHSA-wwh8-v3j3-gxfw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Remote attackers can view the status of arbitrary orders in WooCommerce by manipulating the order_id parameter, exposing sensitive customer data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"woocommerce","vendor":"woocommerce"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the status of arbitrary orders via the order_id parameter in a fetch_order_status action.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WooCommerce Incorrect Authorization","id":"CVE-2020-29156","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Other in n/a","id":"CVE-2020-29157"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.0"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":null,"source":"GHSA-wwh8-v3j3-gxfw"},{"ecosystem":"Packagist","fixed":["4.7.0"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":"pkg:composer/woocommerce/woocommerce","source":"GHSA-wwh8-v3j3-gxfw"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2020-29147"},"products":["n/a"],"published":"2020-12-27","related":[{"cvss_score":8.8,"headline":"WooCommerce Cross-Site Request Forgery (CSRF)","id":"CVE-2019-20891","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2017-18356","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":8.1,"headline":"Path traversal in n/a","id":"CVE-2018-20714","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":6.1,"headline":"WooCommerce \u003c= 9.4.2 - PostMessage-Based Cross-Site Scripting","id":"CVE-2025-5062","kev_date_added":null,"published":"2025-05-22"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-9168","kev_date_added":null,"published":"2019-02-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2015-2329","kev_date_added":null,"published":"2018-02-08"},{"cvss_score":5.9,"headline":"WordPress Product page shipping calculator for WooCommerce Plugin \u003c= 1.3.25 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-32575","kev_date_added":null,"published":"2023-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can view the status of arbitrary orders in WooCommerce by manipulating the order_id parameter, exposing sensitive customer data.","url":"https://insights.sbomify.com/CVE-2020-29156/"}