# CVE-2020-29156: WooCommerce Incorrect Authorization

> Remote attackers can view the status of arbitrary orders in WooCommerce by manipulating the order_id parameter, exposing sensitive customer data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wwh8-v3j3-gxfw

## What is CVE-2020-29156?

CVE-2020-29156 is a medium-severity missing authorization vulnerability in n/a, published on 27 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the status of arbitrary orders via the order_id parameter in a fetch_order_status action.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2020-29156?

2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `woocommerce/woocommerce` | Packagist | All versions | 4.7.0 |
| `woocommerce/woocommerce` | Packagist | All versions | 4.7.0 |

Products: Woocommerce Woocommerce.

## How do I fix CVE-2020-29156?

Upgrade woocommerce/woocommerce to 4.7.0 or later.

## Is CVE-2020-29156 being exploited?

There is no known exploitation of CVE-2020-29156 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-20891](https://insights.sbomify.com/CVE-2019-20891/): WooCommerce Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2017-18356](https://insights.sbomify.com/CVE-2017-18356/): Code injection in n/a (high 8.8)
- [CVE-2018-20714](https://insights.sbomify.com/CVE-2018-20714/): Path traversal in n/a (high 8.1)
- [CVE-2025-5062](https://insights.sbomify.com/CVE-2025-5062/): WooCommerce <= 9.4.2 - PostMessage-Based Cross-Site Scripting (medium 6.1)
- [CVE-2019-9168](https://insights.sbomify.com/CVE-2019-9168/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29156 and fix it if it is affected.

What it is: CVE-2020-29156 is a medium-severity missing authorization vulnerability in n/a, published on 27 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-29156 in the wild and no public exploit code.

Affected packages and fixed versions:
- woocommerce/woocommerce (Packagist): affected all versions; fixed in 4.7.0
- woocommerce/woocommerce (Packagist): affected all versions; fixed in 4.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29156/ (Markdown: https://insights.sbomify.com/CVE-2020-29156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29156
- OSV: https://osv.dev/vulnerability/CVE-2020-29156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29156/
Summaries are generated and may contain mistakes; the official description above is the record.
