CVE-2020-2922 Information disclosure in MySQL Server
An unauthenticated attacker can exploit a difficult-to-exploit vulnerability in the MySQL Client C API to gain unauthorized read access to a subset of accessible data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-2922?
CVE-2020-2922 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.47 and prior, 5.7.29 and prior and 8.0.18 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Client accessible data. CVSS 3.0 Base Score 3.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).
Which versions are affected by CVE-2020-2922?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
mariadb-min Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
mysql-client Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
Products include Canonical Ubuntu Linux, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter and 1 more.
How do I fix CVE-2020-2922?
Upgrade mariadb to a fixed version for your release line: 5.5.65, 10.1.41, 10.2.26 or 10.3.17.
Is CVE-2020-2922 being exploited?
There is no known exploitation of CVE-2020-2922 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-mariadb-2020-2922, BIT-mariadb-min-2020-2922, BIT-mysql-client-2020-2922, GHSA-95hr-j7p7-26x4, UBUNTU-CVE-2020-2922.