# CVE-2020-2922: Information disclosure in MySQL Server

> An unauthenticated attacker can exploit a difficult-to-exploit vulnerability in the MySQL Client C API to gain unauthorized read access to a subset of accessible data.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2020
- **Updated:** 27 Sep 2024
- **Also known as:** BIT-mariadb-2020-2922, BIT-mariadb-min-2020-2922, BIT-mysql-client-2020-2922, GHSA-95hr-j7p7-26x4, UBUNTU-CVE-2020-2922

## What is CVE-2020-2922?

CVE-2020-2922 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.47 and prior, 5.7.29 and prior and 8.0.18 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Client accessible data. CVSS 3.0 Base Score 3.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).

## Which versions are affected by CVE-2020-2922?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
| `mariadb-min` | Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |
| `mysql-client` | Bitnami | From 5.5.0 | 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7 |

Products: Canonical Ubuntu Linux, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql.

## How do I fix CVE-2020-2922?

Upgrade mariadb to a fixed version for your release line: 5.5.65, 10.1.41, 10.2.26 or 10.3.17.

## Is CVE-2020-2922 being exploited?

There is no known exploitation of CVE-2020-2922 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2922 and fix it if it is affected.

What it is: CVE-2020-2922 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2922 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 5.5.0; fixed in 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7
- mariadb-min (Bitnami): affected from 5.5.0; fixed in 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7
- mysql-client (Bitnami): affected from 5.5.0; fixed in 5.5.65, 10.1.41, 10.2.26, 10.3.17, 10.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2922/ (Markdown: https://insights.sbomify.com/CVE-2020-2922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2922
- OSV: https://osv.dev/vulnerability/CVE-2020-2922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2922/
Summaries are generated and may contain mistakes; the official description above is the record.
