{"answers":{"affected":"2 open source packages ship an affected version, including blosc2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-29367 in the wild and no public exploit code.","fix":"Upgrade blosc2 to 0.1.7 or later.","what":"CVE-2020-29367 is a high-severity memory corruption vulnerability in n/a, published on 27 Nov 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-29367 and fix it if it is affected.\n\nWhat it is: CVE-2020-29367 is a high-severity memory corruption vulnerability in n/a, published on 27 Nov 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-29367 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- blosc2 (PyPI): affected all versions; fixed in 0.1.7\n- blosc2 (PyPI): affected all versions; fixed in 0.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-29367/ (Markdown: https://insights.sbomify.com/CVE-2020-29367/index.md)","id":"CVE-2020-29367","markdown":"https://insights.sbomify.com/CVE-2020-29367/index.md","name":"CVE-2020-29367","record":{"aliases":["GHSA-8c7c-2c8j-3xfp","MGASA-2021-0051","openSUSE-SU-2020:2337-1","openSUSE-SU-2024:10655-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"C-Blosc2 compression library","requires_auth":"none","summary":"A heap-based buffer overflow in the C-Blosc2 library allows attackers to execute arbitrary code or cause denial of service via crafted compressed data.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"c-blosc2","vendor":"blosc"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"blosc2.c in Blosc C-Blosc2 through 2.0.0.beta.5 has a heap-based buffer overflow when there is a lack of space to write compressed data.","ecosystems":["PyPI","SUSE:Package Hub 15 SP1","SUSE:Package Hub 15 SP2","openSUSE:Leap 15.1","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"blosc2 heap-based buffer overflow","id":"CVE-2020-29367","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2020"},"n_packages":6,"n_references":2,"next":{"headline":"Race condition in n/a","id":"CVE-2020-29368"},"packages":[{"ecosystem":"PyPI","fixed":["0.1.7"],"introduced":["0"],"last_affected":[],"package":"blosc2","purl":null,"source":"GHSA-8c7c-2c8j-3xfp"},{"ecosystem":"PyPI","fixed":["0.1.7"],"introduced":["0"],"last_affected":[],"package":"blosc2","purl":"pkg:pypi/blosc2","source":"GHSA-8c7c-2c8j-3xfp"},{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["1.20.1-bp152.4.3.1"],"introduced":["0"],"last_affected":[],"package":"blosc","purl":"pkg:rpm/suse/blosc\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2020:2337-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["1.20.1-bp152.4.3.1"],"introduced":["0"],"last_affected":[],"package":"blosc","purl":"pkg:rpm/suse/blosc\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2020:2337-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["1.20.1-bp152.4.3.1"],"introduced":["0"],"last_affected":[],"package":"blosc","purl":"pkg:rpm/opensuse/blosc\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:2337-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["1.20.1-bp152.4.3.1"],"introduced":["0"],"last_affected":[],"package":"blosc","purl":"pkg:rpm/opensuse/blosc\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2020:2337-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-29364"},"products":["n/a"],"published":"2020-11-27","related":[{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37185","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37186","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37187","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37188","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.3,"headline":"c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow","id":"CVE-2024-3203","kev_date_added":null,"published":"2024-04-02"},{"cvss_score":7.3,"headline":"c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow","id":"CVE-2024-3204","kev_date_added":null,"published":"2024-04-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A heap-based buffer overflow in the C-Blosc2 library allows attackers to execute arbitrary code or cause denial of service via crafted compressed data.","url":"https://insights.sbomify.com/CVE-2020-29367/"}