# CVE-2020-29367: blosc2 heap-based buffer overflow

> A heap-based buffer overflow in the C-Blosc2 library allows attackers to execute arbitrary code or cause denial of service via crafted compressed data.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8c7c-2c8j-3xfp, MGASA-2021-0051, openSUSE-SU-2020:2337-1, openSUSE-SU-2024:10655-1

## What is CVE-2020-29367?

CVE-2020-29367 is a high-severity memory corruption vulnerability in n/a, published on 27 Nov 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

blosc2.c in Blosc C-Blosc2 through 2.0.0.beta.5 has a heap-based buffer overflow when there is a lack of space to write compressed data.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-29367?

2 open source packages ship an affected version, including blosc2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `blosc2` | PyPI | All versions | 0.1.7 |
| `blosc2` | PyPI | All versions | 0.1.7 |
| `blosc` | SUSE:Package Hub 15 SP1 | All versions | 1.20.1-bp152.4.3.1 |
| `blosc` | SUSE:Package Hub 15 SP2 | All versions | 1.20.1-bp152.4.3.1 |
| `blosc` | openSUSE:Leap 15.1 | All versions | 1.20.1-bp152.4.3.1 |
| `blosc` | openSUSE:Leap 15.2 | All versions | 1.20.1-bp152.4.3.1 |

Products: Blosc C-Blosc2.

## How do I fix CVE-2020-29367?

Upgrade blosc2 to 0.1.7 or later.

## Is CVE-2020-29367 being exploited?

There is no known exploitation of CVE-2020-29367 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-37185](https://insights.sbomify.com/CVE-2023-37185/): Null dereference in n/a (high 7.5)
- [CVE-2023-37186](https://insights.sbomify.com/CVE-2023-37186/): Null dereference in n/a (high 7.5)
- [CVE-2023-37187](https://insights.sbomify.com/CVE-2023-37187/): Null dereference in n/a (high 7.5)
- [CVE-2023-37188](https://insights.sbomify.com/CVE-2023-37188/): Null dereference in n/a (high 7.5)
- [CVE-2024-3203](https://insights.sbomify.com/CVE-2024-3203/): c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29367 and fix it if it is affected.

What it is: CVE-2020-29367 is a high-severity memory corruption vulnerability in n/a, published on 27 Nov 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-29367 in the wild and no public exploit code.

Affected packages and fixed versions:
- blosc2 (PyPI): affected all versions; fixed in 0.1.7
- blosc2 (PyPI): affected all versions; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29367/ (Markdown: https://insights.sbomify.com/CVE-2020-29367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29367
- OSV: https://osv.dev/vulnerability/CVE-2020-29367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29367/
Summaries are generated and may contain mistakes; the official description above is the record.
