CVE-2020-29396 Code injection in Odoo Community
Authenticated users can bypass sandboxing to execute arbitrary code and escalate privileges in Odoo Community and Enterprise.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-29396?
CVE-2020-29396 is a critical code injection vulnerability in Odoo Odoo, published on 22 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A sandboxing issue in Odoo Community 11.0 through 13.0 and Odoo Enterprise 11.0 through 13.0, when running with Python 3.6 or later, allows remote authenticated users to execute arbitrary code, leading to privilege escalation.
Weakness: CWE-267
Which versions are affected by CVE-2020-29396?
1 open source package ship an affected version, including odoo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
odoo Bitnami | From 11.0.0 | 13.0.1 |
Products include Odoo Odoo.
How do I fix CVE-2020-29396?
Upgrade odoo to 13.0.1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-29396 being exploited?
There is no known exploitation of CVE-2020-29396 in the wild and no public exploit code.
Other vulnerabilities in Odoo Odoo
Sources
Also known as BIT-odoo-2020-29396, GHSA-fg5r-c9qq-q3wm, UBUNTU-CVE-2020-29396.