# CVE-2020-29396: Code injection in Odoo Community

> Authenticated users can bypass sandboxing to execute arbitrary code and escalate privileges in Odoo Community and Enterprise.

- **Severity:** Critical 9.9 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-odoo-2020-29396, GHSA-fg5r-c9qq-q3wm, UBUNTU-CVE-2020-29396

## What is CVE-2020-29396?

CVE-2020-29396 is a critical code injection vulnerability in Odoo Odoo, published on 22 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandboxing issue in Odoo Community 11.0 through 13.0 and Odoo Enterprise 11.0 through 13.0, when running with Python 3.6 or later, allows remote authenticated users to execute arbitrary code, leading to privilege escalation.

Weakness: CWE-267 (Privilege Defined With Unsafe Actions)

## Which versions are affected by CVE-2020-29396?

1 open source package ship an affected version, including odoo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `odoo` | Bitnami | From 11.0.0 | 13.0.1 |

Products: Odoo Odoo.

## How do I fix CVE-2020-29396?

Upgrade odoo to 13.0.1 or later.

## Is CVE-2020-29396 being exploited?

There is no known exploitation of CVE-2020-29396 in the wild and no public exploit code.

## Other vulnerabilities in Odoo Odoo

- [CVE-2018-14885](https://insights.sbomify.com/CVE-2018-14885/): Auth bypass in n/a (critical 9.8)
- [CVE-2017-10804](https://insights.sbomify.com/CVE-2017-10804/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-14860](https://insights.sbomify.com/CVE-2018-14860/): Code injection in n/a (critical 9.1)
- [CVE-2017-10805](https://insights.sbomify.com/CVE-2017-10805/): Auth bypass in n/a (high 8.8)
- [CVE-2021-23166](https://insights.sbomify.com/CVE-2021-23166/): Path traversal in Odoo Community (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29396 and fix it if it is affected.

What it is: CVE-2020-29396 is a critical code injection vulnerability in Odoo Odoo, published on 22 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-29396 in the wild and no public exploit code.

Affected packages and fixed versions:
- odoo (Bitnami): affected from 11.0.0; fixed in 13.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29396/ (Markdown: https://insights.sbomify.com/CVE-2020-29396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29396
- OSV: https://osv.dev/vulnerability/CVE-2020-29396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29396/
Summaries are generated and may contain mistakes; the official description above is the record.
