{"answers":{"affected":"3 open source packages ship an affected version, including papermerge. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-29456 in the wild and no public exploit code.","fix":"Upgrade papermerge to 1.5.2 or later.","what":"CVE-2020-29456 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-29456 and fix it if it is affected.\n\nWhat it is: CVE-2020-29456 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-29456 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- papermerge (PyPI): affected from 1.2.0; fixed in 1.5.2\n- papermerge (PyPI): affected from 1.2.0; fixed in 1.5.2\n- papermerge (PyPI): affected from 1.2.0; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-29456/ (Markdown: https://insights.sbomify.com/CVE-2020-29456/index.md)","id":"CVE-2020-29456","markdown":"https://insights.sbomify.com/CVE-2020-29456/index.md","name":"CVE-2020-29456","record":{"aliases":["GHSA-9w49-m7xh-5r39","PYSEC-2020-74"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Papermerge document management","requires_auth":"none","summary":"Remote attackers can inject arbitrary scripts via filenames or tags, potentially executing code without authentication if email consumption is enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"papermerge","vendor":"papermerge"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in papermerge","id":"CVE-2020-29456","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":3,"n_references":3,"next":{"headline":"Improper Certificate Validation in OPCFoundation.NetStandard.Opc.Ua.Core","id":"CVE-2020-29457"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["1.2.0"],"last_affected":[],"package":"papermerge","purl":null,"source":"GHSA-9w49-m7xh-5r39"},{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["1.2.0"],"last_affected":[],"package":"papermerge","purl":"pkg:pypi/papermerge","source":"GHSA-9w49-m7xh-5r39"},{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["1.2.0"],"last_affected":[],"package":"papermerge","purl":"pkg:pypi/papermerge","source":"PYSEC-2020-74"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-29455"},"products":["n/a"],"published":"2020-12-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary scripts via filenames or tags, potentially executing code without authentication if email consumption is enabled.","url":"https://insights.sbomify.com/CVE-2020-29456/"}