# CVE-2020-29457: Improper Certificate Validation in OPCFoundation.NetStandard.Opc.Ua.Core

> A rogue application can establish a secure connection in the OPC UA .NET Standard Stack, leading to privilege elevation.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mjww-934m-h4jw

## What is CVE-2020-29457?

CVE-2020-29457 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Privilege Elevation vulnerability in OPC UA .NET Standard Stack 1.4.363.107 could allow a rogue application to establish a secure connection.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-29457?

2 open source packages ship an affected version, including OPCFoundation.NetStandard.Opc.Ua.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OPCFoundation.NetStandard.Opc.Ua.Core` | NuGet | All versions | 1.4.365.10 |
| `OPCFoundation.NetStandard.Opc.Ua.Core` | NuGet | All versions | 1.4.365.10 |

Products: Opcfoundation Ua-.Netstandard.

## How do I fix CVE-2020-29457?

Upgrade OPCFoundation.NetStandard.Opc.Ua.Core to 1.4.365.10 or later.

## Is CVE-2020-29457 being exploited?

There is no known exploitation of CVE-2020-29457 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-27321](https://insights.sbomify.com/CVE-2023-27321/): OPC Foundation UA .NET Standard ConditionRefresh Resource Exhaustion Denial-of-Service Vulnerability (high 7.5)
- [CVE-2023-31048](https://insights.sbomify.com/CVE-2023-31048/): Exposure of Sensitive Information in OPC UA .NET Standard Reference Server (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29457 and fix it if it is affected.

What it is: CVE-2020-29457 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-29457 in the wild and no public exploit code.

Affected packages and fixed versions:
- OPCFoundation.NetStandard.Opc.Ua.Core (NuGet): affected all versions; fixed in 1.4.365.10
- OPCFoundation.NetStandard.Opc.Ua.Core (NuGet): affected all versions; fixed in 1.4.365.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29457/ (Markdown: https://insights.sbomify.com/CVE-2020-29457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29457
- OSV: https://osv.dev/vulnerability/CVE-2020-29457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29457/
Summaries are generated and may contain mistakes; the official description above is the record.
