# CVE-2020-29555: Grav CMS Arbitrary File Deletion

> Authenticated or unauthenticated attackers can delete arbitrary files on the server via path traversal in Grav CMS BackupDelete functionality.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gpmf-q5jh-hjx4

## What is CVE-2020-29555?

CVE-2020-29555 is a high-severity path traversal vulnerability in n/a, published on 15 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The BackupDelete functionality in Grav CMS through 1.7.0-rc.17 allows an authenticated attacker to delete arbitrary files on the underlying server by exploiting a path-traversal technique. (This vulnerability can also be exploited by an unauthenticated attacker due to a lack of CSRF protection.)

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-29555?

4 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.6.30 |
| `getgrav/grav` | Packagist | All versions | 1.6.30 |
| `getgrav/grav` | Packagist | From 1.7.0-beta.1 to 1.7.0-rc.17 | None |
| `getgrav/grav` | Packagist | From 1.7.0-beta.1 to 1.7.0-rc.17 | None |

Products: Getgrav Grav Cms.

## How do I fix CVE-2020-29555?

Upgrade getgrav/grav to 1.6.30 or later.

## Is CVE-2020-29555 being exploited?

There is no known exploitation of CVE-2020-29555 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-29553](https://insights.sbomify.com/CVE-2020-29553/): Grav CMS Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2019-16126](https://insights.sbomify.com/CVE-2019-16126/): Cross-site Scripting in Grav (medium 6.1)
- [CVE-2018-5233](https://insights.sbomify.com/CVE-2018-5233/): Grav CMS Cross-site scripting (XSS) vulnerability (medium 6.1)
- [CVE-2020-29556](https://insights.sbomify.com/CVE-2020-29556/): Grav CMS Local File Injection (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29555 and fix it if it is affected.

What it is: CVE-2020-29555 is a high-severity path traversal vulnerability in n/a, published on 15 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-29555 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.6.30
- getgrav/grav (Packagist): affected all versions; fixed in 1.6.30
- getgrav/grav (Packagist): affected from 1.7.0-beta.1 up to 1.7.0-rc.17; no fix listed
- getgrav/grav (Packagist): affected from 1.7.0-beta.1 up to 1.7.0-rc.17; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29555/ (Markdown: https://insights.sbomify.com/CVE-2020-29555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29555
- OSV: https://osv.dev/vulnerability/CVE-2020-29555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29555/
Summaries are generated and may contain mistakes; the official description above is the record.
