# CVE-2020-29565: OpenStack Horizon Open redirect in workflow forms

> Attackers can redirect users to malicious URLs via an unvalidated next parameter in OpenStack Horizon, potentially facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-29565, DSA-4820-1, GHSA-f8fh-xp28-q59m, PYSEC-2020-45, RHSA-2020:5411, RHSA-2020:5572, SUSE-SU-2021:0099-1, UBUNTU-CVE-2020-29565, USN-4675-1

## What is CVE-2020-29565?

CVE-2020-29565 is a medium-severity vulnerability in Debian Debian Linux, published on 4 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in OpenStack Horizon before 15.3.2, 16.x before 16.2.1, 17.x and 18.x before 18.3.3, 18.4.x, and 18.5.x. There is a lack of validation of the "next" parameter, which would allow someone to supply a malicious URL in Horizon that can cause an automatic redirect to the provided malicious URL.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2020-29565?

9 open source packages ship an affected version, including horizon. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `horizon` | PyPI | All versions | 15.3.2 |
| `horizon` | PyPI | All versions | 15.3.2 |
| `horizon` | PyPI | From 15.3.0 | 15.3.2, 16.2.1, 18.3.3, 18.6.0 |
| `horizon` | PyPI | From 16.0.0 | 16.2.1 |
| `horizon` | PyPI | From 16.0.0 | 16.2.1 |
| `horizon` | PyPI | From 17.0.0 | 18.3.3 |
| `horizon` | PyPI | From 17.0.0 | 18.3.3 |
| `horizon` | PyPI | From 18.4.0 | 18.6.0 |
| `horizon` | PyPI | From 18.4.0 | 18.6.0 |
| `openstack-dashboard` | Red Hat:openstack:13::el7 | All versions | 1:13.0.3-7.el7ost |
| `python-django-horizon` | Red Hat:openstack:13::el7 | All versions | 1:13.0.3-7.el7ost |
| `openstack-dashboard` | Red Hat:openstack:16.1::el8 | All versions | 1:16.2.1-1.20201114033610.el8ost |
| `python-django-horizon` | Red Hat:openstack:16.1::el8 | All versions | 1:16.2.1-1.20201114033610.el8ost |
| `python3-django-horizon` | Red Hat:openstack:16.1::el8 | All versions | 1:16.2.1-1.20201114033610.el8ost |
| `openstack-dashboard` | SUSE:HPE Helion OpenStack 8 | All versions | 12.0.5~dev6-3.29.1 |
| `release-notes-hpe-helion-openstack` | SUSE:HPE Helion OpenStack 8 | All versions | 8.20201214-3.26.1 |
| `openstack-dashboard` | SUSE:OpenStack Cloud 8 | All versions | 12.0.5~dev6-3.29.1 |
| `release-notes-suse-openstack-cloud` | SUSE:OpenStack Cloud 8 | All versions | 8.20201214-3.26.1 |
| `openstack-dashboard` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 12.0.5~dev6-3.29.1 |
| `release-notes-suse-openstack-cloud` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 8.20201214-3.26.1 |

Products: Debian Debian Linux, Openstack Horizon.

## How do I fix CVE-2020-29565?

Upgrade horizon to a fixed version for your release line: 15.3.2, 16.2.1, 18.3.3 or 18.6.0.

## Is CVE-2020-29565 being exploited?

There is no known exploitation of CVE-2020-29565 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-29565 and fix it if it is affected.

What it is: CVE-2020-29565 is a medium-severity vulnerability in Debian Debian Linux, published on 4 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-29565 in the wild and no public exploit code.

Affected packages and fixed versions:
- horizon (PyPI): affected all versions; fixed in 15.3.2
- horizon (PyPI): affected all versions; fixed in 15.3.2
- horizon (PyPI): affected from 15.3.0; fixed in 15.3.2, 16.2.1, 18.3.3, 18.6.0
- horizon (PyPI): affected from 16.0.0; fixed in 16.2.1
- horizon (PyPI): affected from 16.0.0; fixed in 16.2.1
- horizon (PyPI): affected from 17.0.0; fixed in 18.3.3
- horizon (PyPI): affected from 17.0.0; fixed in 18.3.3
- horizon (PyPI): affected from 18.4.0; fixed in 18.6.0
- horizon (PyPI): affected from 18.4.0; fixed in 18.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-29565/ (Markdown: https://insights.sbomify.com/CVE-2020-29565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-29565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-29565
- OSV: https://osv.dev/vulnerability/CVE-2020-29565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-29565/
Summaries are generated and may contain mistakes; the official description above is the record.
