# CVE-2020-35128: Mautic stored Cross-site Scripting (XSS)

> Stored XSS in Mautic allows attackers with company management permissions to execute scripts, potentially taking over admin accounts and modifying user data.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** CVE-2021-3142, GHSA-98j2-3jv7-274m

## What is CVE-2020-35128?

CVE-2020-35128 is a critical cross-site scripting vulnerability in n/a, published on 19 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mautic before 3.2.4 is affected by stored XSS. An attacker with permission to manage companies, an application feature, could attack other users, including administrators. For example, by loading an externally crafted JavaScript file, an attacker could eventually perform actions as the target user. These actions include changing the user passwords, altering user or email addresses, or adding a new administrator to the system.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-35128?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | From 2.0.0 | 2.16.5 |
| `mautic/core` | Packagist | From 2.0.0 | 2.16.5 |
| `mautic/core` | Packagist | From 3.2.0 | 3.2.4 |
| `mautic/core` | Packagist | From 3.2.0 | 3.2.4 |

Products: Acquia Mautic.

## How do I fix CVE-2020-35128?

Upgrade mautic/core to a fixed version for your release line: 2.16.5 or 3.2.4.

## Is CVE-2020-35128 being exploited?

There is no known exploitation of CVE-2020-35128 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2024-47051](https://insights.sbomify.com/CVE-2024-47051/): Remote Code Execution & File Deletion in Asset Uploads (critical 9.1)
- [CVE-2017-8874](https://insights.sbomify.com/CVE-2017-8874/): Mautic Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35128 and fix it if it is affected.

What it is: CVE-2020-35128 is a critical cross-site scripting vulnerability in n/a, published on 19 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-35128 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected from 2.0.0; fixed in 2.16.5
- mautic/core (Packagist): affected from 2.0.0; fixed in 2.16.5
- mautic/core (Packagist): affected from 3.2.0; fixed in 3.2.4
- mautic/core (Packagist): affected from 3.2.0; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35128/ (Markdown: https://insights.sbomify.com/CVE-2020-35128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35128
- OSV: https://osv.dev/vulnerability/CVE-2020-35128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35128/
Summaries are generated and may contain mistakes; the official description above is the record.
