# CVE-2020-35234: Information disclosure in n/a

> An attacker can gain Administrator access by reading debug logs containing password reset links in the Easy WP SMTP plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m9j8-w3jp-p7wq

## What is CVE-2020-35234?

CVE-2020-35234 is a high-severity vulnerability in n/a, published on 14 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The easy-wp-smtp plugin before 1.4.4 for WordPress allows Administrator account takeover, as exploited in the wild in December 2020. If an attacker can list the wp-content/plugins/easy-wp-smtp/ directory, then they can discover a log file (such as #############_debug_log.txt) that contains all password-reset links. The attacker can request a reset of the Administrator password and then use a link found there.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2020-35234?

It affects 1 product.


Products: Wp-Ecommerce Easy Wp Smtp.

## How do I fix CVE-2020-35234?

No fix has been published for CVE-2020-35234 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-35234 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-35234 exists.

Public exploit code:

- WordPress Easy WP SMTP Password Reset (metasploit)
- SMTP WP Plugin Directory Listing (nuclei): http/cves/2020/CVE-2020-35234.yaml

## Other vulnerabilities in n/a

- [CVE-2019-25141](https://insights.sbomify.com/CVE-2019-25141/): Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update (critical 9.8)
- [CVE-2022-42699](https://insights.sbomify.com/CVE-2022-42699/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Remote Code Execution (RCE) (critical 9.1)
- [CVE-2022-45829](https://insights.sbomify.com/CVE-2022-45829/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Arbitrary File Deletion (high 8.7)
- [CVE-2022-3334](https://insights.sbomify.com/CVE-2022-3334/): Easy WP SMTP < 1.5.0 - Admin+ PHP Objection Injection (high 7.2)
- [CVE-2022-45833](https://insights.sbomify.com/CVE-2022-45833/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Directory Traversal (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35234 and fix it if it is affected.

What it is: CVE-2020-35234 is a high-severity vulnerability in n/a, published on 14 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-35234 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35234/ (Markdown: https://insights.sbomify.com/CVE-2020-35234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35234
- OSV: https://osv.dev/vulnerability/CVE-2020-35234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35234/
Summaries are generated and may contain mistakes; the official description above is the record.
