CVE-2020-35239 CakePHP allows method override parameters to bypass CSRF checks
Attackers can bypass CSRF protection in CakePHP by using arbitrary method override parameters, allowing unauthorized state-changing requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-35239?
CVE-2020-35239 is a high-severity vulnerability in n/a, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. The CsrfProtectionMiddleware component allows method override parameters to bypass CSRF checks by changing the HTTP request method to an arbitrary string that is not in the list of request methods that CakePHP checks. Additionally, the route middleware does not verify that this overriden method (which can be an arbitrary string) is actually an HTTP method.
Weakness: CWE-352
Which versions are affected by CVE-2020-35239?
4 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/cakephp Packagist | From 4.0.0 | 4.0.10 |
cakephp/cakephp Packagist | From 4.0.0 | 4.0.10 |
cakephp/cakephp Packagist | From 4.1.0 | 4.1.4 |
cakephp/cakephp Packagist | From 4.1.0 | 4.1.4 |
Products include Cakephp Cakephp.
How do I fix CVE-2020-35239?
Upgrade cakephp/cakephp to a fixed version for your release line: 4.0.10 or 4.1.4.
Is CVE-2020-35239 being exploited?
There is no known exploitation of CVE-2020-35239 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2023-22727 Database Query::offset() and limit() vulnerable to SQL injection in cakephp
- CVE-2015-8379 CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter
- CVE-2019-11458 Unsafe deserialization in SmtpTransport in CakePHP
- CVE-2016-4793 CakePHP allows remote attackers to spoof their IP
- CVE-2026-23643 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Sources
Also known as GHSA-9pgx-pf36-w46r, UBUNTU-CVE-2020-35239.