# CVE-2020-35239: CakePHP allows method override parameters to bypass CSRF checks

> Attackers can bypass CSRF protection in CakePHP by using arbitrary method override parameters, allowing unauthorized state-changing requests.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9pgx-pf36-w46r, UBUNTU-CVE-2020-35239

## What is CVE-2020-35239?

CVE-2020-35239 is a high-severity vulnerability in n/a, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. The CsrfProtectionMiddleware component allows method override parameters to bypass CSRF checks by changing the HTTP request method to an arbitrary string that is not in the list of request methods that CakePHP checks. Additionally, the route middleware does not verify that this overriden method (which can be an arbitrary string) is actually an HTTP method.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-35239?

4 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/cakephp` | Packagist | From 4.0.0 | 4.0.10 |
| `cakephp/cakephp` | Packagist | From 4.0.0 | 4.0.10 |
| `cakephp/cakephp` | Packagist | From 4.1.0 | 4.1.4 |
| `cakephp/cakephp` | Packagist | From 4.1.0 | 4.1.4 |

Products: Cakephp Cakephp.

## How do I fix CVE-2020-35239?

Upgrade cakephp/cakephp to a fixed version for your release line: 4.0.10 or 4.1.4.

## Is CVE-2020-35239 being exploited?

There is no known exploitation of CVE-2020-35239 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22727](https://insights.sbomify.com/CVE-2023-22727/): Database Query::offset() and limit() vulnerable to SQL injection in cakephp (critical 9.8)
- [CVE-2015-8379](https://insights.sbomify.com/CVE-2015-8379/): CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter (high 8.8)
- [CVE-2019-11458](https://insights.sbomify.com/CVE-2019-11458/): Unsafe deserialization in SmtpTransport in CakePHP (high 7.5)
- [CVE-2016-4793](https://insights.sbomify.com/CVE-2016-4793/): CakePHP allows remote attackers to spoof their IP (high 7.5)
- [CVE-2026-23643](https://insights.sbomify.com/CVE-2026-23643/): CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35239 and fix it if it is affected.

What it is: CVE-2020-35239 is a high-severity vulnerability in n/a, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-35239 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/cakephp (Packagist): affected from 4.0.0; fixed in 4.0.10
- cakephp/cakephp (Packagist): affected from 4.0.0; fixed in 4.0.10
- cakephp/cakephp (Packagist): affected from 4.1.0; fixed in 4.1.4
- cakephp/cakephp (Packagist): affected from 4.1.0; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35239/ (Markdown: https://insights.sbomify.com/CVE-2020-35239/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35239
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35239
- OSV: https://osv.dev/vulnerability/CVE-2020-35239

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35239/
Summaries are generated and may contain mistakes; the official description above is the record.
