# CVE-2020-35305: Gollum Cross-site Scripting vulnerability via filename parameter to New Page dialog

> An attacker can execute arbitrary scripts in the victim's browser via the filename parameter in the New Page dialog of the Gollum wiki.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2022
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-fj2w-qmjp-3rjm

## What is CVE-2020-35305?

CVE-2020-35305 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross site scripting (XSS) in gollum 5.0 to 5.1.2 via the filename parameter to the 'New Page' dialog.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-35305?

2 open source packages ship an affected version, including gollum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gollum` | RubyGems | From 5.0 | 5.1.2 |
| `gollum` | RubyGems | From 5.0 | 5.1.2 |

Products: Gollum Project Gollum.

## How do I fix CVE-2020-35305?

Upgrade gollum to 5.1.2 or later.

## Is CVE-2020-35305 being exploited?

There is no known exploitation of CVE-2020-35305 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-9489](https://insights.sbomify.com/CVE-2014-9489/): gollum and gollum-lib allow remote authenticated users to execute arbitrary code (high 8.8)
- [CVE-2015-7314](https://insights.sbomify.com/CVE-2015-7314/): Gollum Exposure of Sensitive Information (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35305 and fix it if it is affected.

What it is: CVE-2020-35305 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-35305 in the wild and no public exploit code.

Affected packages and fixed versions:
- gollum (RubyGems): affected from 5.0; fixed in 5.1.2
- gollum (RubyGems): affected from 5.0; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35305/ (Markdown: https://insights.sbomify.com/CVE-2020-35305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35305
- OSV: https://osv.dev/vulnerability/CVE-2020-35305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35305/
Summaries are generated and may contain mistakes; the official description above is the record.
