# CVE-2020-35452: mod_auth_digest possible stack overflow by one nul byte

> A specially crafted Digest nonce can cause a stack overflow in Apache HTTP Server's mod_auth_digest, potentially leading to denial of service.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-35452, AZL-6475, BIT-apache-2020-35452, CLEANSTART-2026-DX94657, CLSA-2021-1633601543, CLSA-2021-1634922624, CLSA-2025-1751271625, DEBIAN-CVE-2020-35452, GHSA-77mj-xh9q-fm9j, UBUNTU-CVE-2020-35452

## What is CVE-2020-35452?

CVE-2020-35452 is a high-severity memory corruption vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-35452?

1 open source package ship an affected version, including apache. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.47 |

Products: Apache Http Server, Debian Debian Linux, Fedoraproject Fedora, Oracle Enterprise Manager Ops Center, Oracle Instantis Enterprisetrack, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2020-35452?

Upgrade apache to 2.4.47 or later.

## Is CVE-2020-35452 being exploited?

There is no known exploitation of CVE-2020-35452 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35452 and fix it if it is affected.

What it is: CVE-2020-35452 is a high-severity memory corruption vulnerability in Apache Http Server, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35452 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35452/ (Markdown: https://insights.sbomify.com/CVE-2020-35452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35452
- OSV: https://osv.dev/vulnerability/CVE-2020-35452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35452/
Summaries are generated and may contain mistakes; the official description above is the record.
