# CVE-2020-35475: Cross-site scripting in n/a

> Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via unescaped HTML in user rights expiry messages.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2020-35475, DEBIAN-CVE-2020-35475, GHSA-qv45-6hw7-469f, UBUNTU-CVE-2020-35475

## What is CVE-2020-35475?

CVE-2020-35475 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 18 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In MediaWiki before 1.35.1, the messages userrights-expiry-current and userrights-expiry-none can contain raw HTML. XSS can happen when a user visits Special:UserRights but does not have rights to change all userrights, and the table on the left side has unchangeable groups in it. (The right column with the changeable groups is not affected and is escaped correctly.)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-35475?

1 open source package ship an affected version, including mediawiki. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2020-35475?

Upgrade mediawiki to 1.35.1 or later.

## Is CVE-2020-35475 being exploited?

There is no known exploitation of CVE-2020-35475 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35475 and fix it if it is affected.

What it is: CVE-2020-35475 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 18 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35475 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35475/ (Markdown: https://insights.sbomify.com/CVE-2020-35475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35475
- OSV: https://osv.dev/vulnerability/CVE-2020-35475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35475/
Summaries are generated and may contain mistakes; the official description above is the record.
