CVE-2020-35509 Keycloak vulnerable to Improper Certificate Validation
Attackers can bypass certificate expiration checks in Keycloak's direct-grant authenticator, potentially compromising data confidentiality and integrity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-35509?
CVE-2020-35509 is a medium-severity vulnerability in Redhat Keycloak, published on 23 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in keycloak affecting versions 11.0.3 and 12.0.0. An expired certificate would be accepted by the direct-grant authenticator because of missing time stamp validations. The highest threat from this vulnerability is to data confidentiality and integrity.
Which versions are affected by CVE-2020-35509?
2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.keycloak:keycloak-core Maven | All versions | 14.0.0 |
org.keycloak:keycloak-core Maven | All versions | 14.0.0 |
Products include Redhat Keycloak.
How do I fix CVE-2020-35509?
Upgrade org.keycloak:keycloak-core to 14.0.0 or later.
Is CVE-2020-35509 being exploited?
There is no known exploitation of CVE-2020-35509 in the wild and no public exploit code.
Other vulnerabilities in Redhat Keycloak
- CVE-2022-4361 Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC
- CVE-2022-1245 Keycloak vulnerable to privilege escalation on Token Exchange feature
- CVE-2021-20195 keycloak Self Stored Cross-site Scripting vulnerability
- CVE-2019-14910 Keycloak Authentication Error
- CVE-2019-14909 Keycloak Authentication Error
Sources
Also known as GHSA-rpj2-w6fr-79hc.