# CVE-2020-35509: Keycloak vulnerable to Improper Certificate Validation

> Attackers can bypass certificate expiration checks in Keycloak's direct-grant authenticator, potentially compromising data confidentiality and integrity.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2022
- **Updated:** 30 Jun 2025
- **Also known as:** GHSA-rpj2-w6fr-79hc

## What is CVE-2020-35509?

CVE-2020-35509 is a medium-severity vulnerability in Redhat Keycloak, published on 23 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in keycloak affecting versions 11.0.3 and 12.0.0. An expired certificate would be accepted by the direct-grant authenticator because of missing time stamp validations. The highest threat from this vulnerability is to data confidentiality and integrity.

Weakness: CWE-295 (Improper Certificate Validation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-35509?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 14.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 14.0.0 |

Products: Redhat Keycloak.

## How do I fix CVE-2020-35509?

Upgrade org.keycloak:keycloak-core to 14.0.0 or later.

## Is CVE-2020-35509 being exploited?

There is no known exploitation of CVE-2020-35509 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35509 and fix it if it is affected.

What it is: CVE-2020-35509 is a medium-severity vulnerability in Redhat Keycloak, published on 23 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35509 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 14.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 14.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35509/ (Markdown: https://insights.sbomify.com/CVE-2020-35509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35509
- OSV: https://osv.dev/vulnerability/CVE-2020-35509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35509/
Summaries are generated and may contain mistakes; the official description above is the record.
