CVE-2020-35662 SaltStack Salt Improper SSL Certificate Validation
Attackers can bypass SSL certificate validation during authentication, enabling man-in-the-middle attacks against SaltStack services.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-35662?
CVE-2020-35662 is a high-severity vulnerability in Debian Debian Linux, published on 27 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In SaltStack Salt before 3002.5, when authenticating to services using certain modules, the SSL certificate is not always validated.
Weakness: CWE-295
Which versions are affected by CVE-2020-35662?
19 open source packages ship an affected version, including salt. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
salt PyPI | All versions | 2015.8.10, 2015.8.13, 2016.3.4, 2016.3.6, 2016.3.8, 2016.11.3, 2016.11.5, 2016.11.10, 2017.7.8, 2019.2.0rc1, 2019.2.5, 2019.2.8, 3000.6, 3001.4, 3002.5 |
salt PyPI | All versions | 2015.8.13 |
salt PyPI | All versions | 2015.8.13 |
salt PyPI | From 2016.11.7 | 2016.11.10 |
salt PyPI | From 2016.11.7 | 2016.11.10 |
salt PyPI | From 2016.3.0 | 2016.11.5 |
13 more packages
salt PyPI | From 2016.3.0 | 2016.11.5 |
salt PyPI | From 2017.5.0 | 2017.7.8 |
salt PyPI | From 2017.5.0 | 2017.7.8 |
salt PyPI | From 2018.2.0 to 2018.3.5 | None |
salt PyPI | From 2018.2.0 to 2018.3.5 | None |
salt PyPI | From 2019.2.0 | 2019.2.8 |
salt PyPI | From 2019.2.0 | 2019.2.8 |
salt PyPI | From 3000 | 3000.7 |
salt PyPI | From 3000 | 3000.7 |
salt PyPI | From 3001 | 3001.5 |
salt PyPI | From 3001 | 3001.5 |
salt PyPI | From 3002 | 3002.3 |
salt PyPI | From 3002 | 3002.3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Saltstack Salt.
How do I fix CVE-2020-35662?
Upgrade salt to a fixed version for your release line: 2015.8.10, 2015.8.13, 2016.3.4 or 2016.3.6.
Is CVE-2020-35662 being exploited?
There is no known exploitation of CVE-2020-35662 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-qx72-q6w3-qgc7, PYSEC-2021-75, UBUNTU-CVE-2020-35662.