# CVE-2020-35669: http before 0.13.3 vulnerable to header injection

> Attackers can inject CRLF sequences into HTTP requests via the Dart http package, potentially leading to request smuggling or header injection.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4rgh-jx4f-qfcq

## What is CVE-2020-35669?

CVE-2020-35669 is a medium-severity vulnerability in n/a, published on 24 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the http package through 0.12.2 for Dart. If the attacker controls the HTTP method and the app is using Request directly, it's possible to achieve CRLF injection in an HTTP request.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-35669?

2 open source packages ship an affected version, including http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `http` | Pub | All versions | 0.13.3 |
| `http` | Pub | All versions | 0.13.3 |

Products: Dart Http.

## How do I fix CVE-2020-35669?

Upgrade http to 0.13.3 or later.

## Is CVE-2020-35669 being exploited?

There is no known exploitation of CVE-2020-35669 in the wild and no public exploit code.

Public exploit code:

- https://github.com/n0npax/CVE-2020-35669 (github_poc): https://github.com/n0npax/CVE-2020-35669

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35669 and fix it if it is affected.

What it is: CVE-2020-35669 is a medium-severity vulnerability in n/a, published on 24 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-35669 in the wild and no public exploit code.

Affected packages and fixed versions:
- http (Pub): affected all versions; fixed in 0.13.3
- http (Pub): affected all versions; fixed in 0.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35669/ (Markdown: https://insights.sbomify.com/CVE-2020-35669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35669
- OSV: https://osv.dev/vulnerability/CVE-2020-35669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35669/
Summaries are generated and may contain mistakes; the official description above is the record.
