{"answers":{"affected":"3 open source packages ship an affected version, including channels. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-35681 in the wild and no public exploit code.","fix":"Upgrade channels to 3.0.3 or later.","what":"CVE-2020-35681 is a high-severity vulnerability in n/a, published on 22 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-35681 and fix it if it is affected.\n\nWhat it is: CVE-2020-35681 is a high-severity vulnerability in n/a, published on 22 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-35681 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- channels (PyPI): affected from 3.0.0; fixed in 3.0.3\n- channels (PyPI): affected from 3.0.0; fixed in 3.0.3\n- channels (PyPI): affected from 3.0.0; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-35681/ (Markdown: https://insights.sbomify.com/CVE-2020-35681/index.md)","id":"CVE-2020-35681","markdown":"https://insights.sbomify.com/CVE-2020-35681/index.md","name":"CVE-2020-35681","record":{"aliases":["DEBIAN-CVE-2020-35681","GHSA-v542-8q9x-cffc","PYSEC-2021-113","UBUNTU-CVE-2020-35681"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Django Channels library","requires_auth":"none","summary":"Remote attackers can obtain sensitive information like session identifiers due to improper request scope separation in legacy HTTP handlers.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"channels","vendor":"djangoproject"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Django Channels 3.x before 3.0.3 allows remote attackers to obtain sensitive information from a different request scope. The legacy channels.http.AsgiHandler class, used for handling HTTP type requests in an ASGI environment prior to Django 3.0, did not correctly separate request scopes in Channels 3.0. In many cases this would result in a crash but, with correct timing, responses could be sent to the wrong client, resulting in potential leakage of session identifiers and other sensitive data. Note that this affects only the legacy Channels provided class, and not Django's similar ASGIHandler, available from Django 3.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Django Channels leakage of session identifiers using legacy AsgiHandler","id":"CVE-2020-35681","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":3,"n_references":3,"next":{"headline":"Auth bypass in n/a","id":"CVE-2020-35682"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"channels","purl":null,"source":"GHSA-v542-8q9x-cffc"},{"ecosystem":"PyPI","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"channels","purl":"pkg:pypi/channels","source":"GHSA-v542-8q9x-cffc"},{"ecosystem":"PyPI","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"channels","purl":"pkg:pypi/channels","source":"PYSEC-2021-113"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2020-35680"},"products":["n/a"],"published":"2021-02-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive information like session identifiers due to improper request scope separation in legacy HTTP handlers.","url":"https://insights.sbomify.com/CVE-2020-35681/"}