# CVE-2020-35681: Django Channels leakage of session identifiers using legacy AsgiHandler

> Remote attackers can obtain sensitive information like session identifiers due to improper request scope separation in legacy HTTP handlers.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Feb 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-35681, GHSA-v542-8q9x-cffc, PYSEC-2021-113, UBUNTU-CVE-2020-35681

## What is CVE-2020-35681?

CVE-2020-35681 is a high-severity vulnerability in n/a, published on 22 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Django Channels 3.x before 3.0.3 allows remote attackers to obtain sensitive information from a different request scope. The legacy channels.http.AsgiHandler class, used for handling HTTP type requests in an ASGI environment prior to Django 3.0, did not correctly separate request scopes in Channels 3.0. In many cases this would result in a crash but, with correct timing, responses could be sent to the wrong client, resulting in potential leakage of session identifiers and other sensitive data. Note that this affects only the legacy Channels provided class, and not Django's similar ASGIHandler, available from Django 3.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-35681?

3 open source packages ship an affected version, including channels. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `channels` | PyPI | From 3.0.0 | 3.0.3 |
| `channels` | PyPI | From 3.0.0 | 3.0.3 |
| `channels` | PyPI | From 3.0.0 | 3.0.3 |

Products: Djangoproject Channels.

## How do I fix CVE-2020-35681?

Upgrade channels to 3.0.3 or later.

## Is CVE-2020-35681 being exploited?

There is no known exploitation of CVE-2020-35681 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35681 and fix it if it is affected.

What it is: CVE-2020-35681 is a high-severity vulnerability in n/a, published on 22 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35681 in the wild and no public exploit code.

Affected packages and fixed versions:
- channels (PyPI): affected from 3.0.0; fixed in 3.0.3
- channels (PyPI): affected from 3.0.0; fixed in 3.0.3
- channels (PyPI): affected from 3.0.0; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35681/ (Markdown: https://insights.sbomify.com/CVE-2020-35681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35681
- OSV: https://osv.dev/vulnerability/CVE-2020-35681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35681/
Summaries are generated and may contain mistakes; the official description above is the record.
