CVE-2020-35730 Roundcube Webmail Cross-Site Scripting (XSS)
Attackers can execute arbitrary JavaScript via crafted plain text emails, potentially leading to session hijacking or account takeover in Roundcube Webmail.
- Exploited in the wild
- Since 22 Jun 2023
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-35730?
CVE-2020-35730 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An XSS issue was discovered in Roundcube Webmail before 1.2.13, 1.3.x before 1.3.16, and 1.4.x before 1.4.10. The attacker can send a plain text e-mail message, with JavaScript in a link reference element that is mishandled by linkref_addindex in rcube_string_replacer.php.
Weakness: CWE-79
Which versions are affected by CVE-2020-35730?
1 open source package ship an affected version, including roundcube. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.2.13, 1.3.16, 1.4.10 |
Products include Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.
How do I fix CVE-2020-35730?
Upgrade roundcube to a fixed version for your release line: 1.2.13, 1.3.16 or 1.4.10. US federal agencies must fix it by 13 Jul 2023.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-35730 being exploited?
Yes. Attackers have exploited CVE-2020-35730 in the wild since at least 22 Jun 2023.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2020-35730, DEBIAN-CVE-2020-35730, DLA-2508-1, DSA-4821-1, GHSA-mr5j-h8xf-5m2m, MGASA-2020-0481 and 1 more.