# CVE-2020-35730: Roundcube Webmail Cross-Site Scripting (XSS)

> Attackers can execute arbitrary JavaScript via crafted plain text emails, potentially leading to session hijacking or account takeover in Roundcube Webmail.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Yes, since 22 Jun 2023 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Dec 2020
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-roundcube-2020-35730, DEBIAN-CVE-2020-35730, DLA-2508-1, DSA-4821-1, GHSA-mr5j-h8xf-5m2m, MGASA-2020-0481, UBUNTU-CVE-2020-35730

## What is CVE-2020-35730?

CVE-2020-35730 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS issue was discovered in Roundcube Webmail before 1.2.13, 1.3.x before 1.3.16, and 1.4.x before 1.4.10. The attacker can send a plain text e-mail message, with JavaScript in a link reference element that is mishandled by linkref_addindex in rcube_string_replacer.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-35730?

1 open source package ship an affected version, including roundcube. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundcube` | Bitnami | All versions | 1.2.13, 1.3.16, 1.4.10 |

Products: Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.

## How do I fix CVE-2020-35730?

Upgrade roundcube to a fixed version for your release line: 1.2.13, 1.3.16 or 1.4.10. US federal agencies must fix it by 13 Jul 2023.

## Is CVE-2020-35730 being exploited?

Yes. Attackers have exploited CVE-2020-35730 in the wild since at least 22 Jun 2023.

Public exploit code:

- Bug Chain XSS (CVE-2020-35730 and CVE-2023-43770) to SQLi (CVE-2021-44026) (github_poc): https://github.com/skyllpro/CVE-2021-44026-PoC

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35730 and fix it if it is affected.

What it is: CVE-2020-35730 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2020-35730 in the wild since at least 22 Jun 2023.

Affected packages and fixed versions:
- roundcube (Bitnami): affected all versions; fixed in 1.2.13, 1.3.16, 1.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35730/ (Markdown: https://insights.sbomify.com/CVE-2020-35730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35730
- OSV: https://osv.dev/vulnerability/CVE-2020-35730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35730/
Summaries are generated and may contain mistakes; the official description above is the record.
