# CVE-2020-35774: TwitterServer Cross-site Scripting via /histograms endpoint

> Cross-site scripting vulnerability in TwitterServer allows attackers to inject scripts via the histograms endpoint in specific configurations.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3mqv-8gxg-pfm4

## What is CVE-2020-35774?

CVE-2020-35774 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

server/handler/HistogramQueryHandler.scala in Twitter TwitterServer (aka twitter-server) before 20.12.0, in some configurations, allows XSS via the /histograms endpoint.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-35774?

2 open source packages ship an affected version, including com.twitter:twitter-server_2.12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.twitter:twitter-server_2.12` | Maven | All versions | 20.12.0 |
| `com.twitter:twitter-server_2.12` | Maven | All versions | 20.12.0 |

Products: Twitter Twitter-Server.

## How do I fix CVE-2020-35774?

Upgrade com.twitter:twitter-server_2.12 to 20.12.0 or later.

## Is CVE-2020-35774 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-35774 exists.

Public exploit code:

- twitter-server Cross-Site Scripting (nuclei): http/cves/2020/CVE-2020-35774.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35774 and fix it if it is affected.

What it is: CVE-2020-35774 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-35774 exists.

Affected packages and fixed versions:
- com.twitter:twitter-server_2.12 (Maven): affected all versions; fixed in 20.12.0
- com.twitter:twitter-server_2.12 (Maven): affected all versions; fixed in 20.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35774/ (Markdown: https://insights.sbomify.com/CVE-2020-35774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35774
- OSV: https://osv.dev/vulnerability/CVE-2020-35774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35774/
Summaries are generated and may contain mistakes; the official description above is the record.
