# CVE-2020-35895: Out-of-bounds write in stack

> An out-of-bounds write in the Rust stack crate allows attackers to cause memory corruption, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h45v-vgvp-3h5v, RUSTSEC-2020-0042

## What is CVE-2020-35895?

CVE-2020-35895 is a critical memory corruption vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the stack crate before 0.3.1 for Rust. ArrayVec has an out-of-bounds write via element insertion.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-35895?

3 open source packages ship an affected version, including stack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stack` | crates.io | All versions | 0.3.1 |
| `stack` | crates.io | All versions | 0.3.1 |
| `stack` | crates.io | From 0.0.0-0 | 0.3.1 |

Products: Stack Project Stack.

## How do I fix CVE-2020-35895?

Upgrade stack to 0.3.1 or later.

## Is CVE-2020-35895 being exploited?

There is no known exploitation of CVE-2020-35895 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35895 and fix it if it is affected.

What it is: CVE-2020-35895 is a critical memory corruption vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35895 in the wild and no public exploit code.

Affected packages and fixed versions:
- stack (crates.io): affected all versions; fixed in 0.3.1
- stack (crates.io): affected all versions; fixed in 0.3.1
- stack (crates.io): affected from 0.0.0-0; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35895/ (Markdown: https://insights.sbomify.com/CVE-2020-35895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35895
- OSV: https://osv.dev/vulnerability/CVE-2020-35895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35895/
Summaries are generated and may contain mistakes; the official description above is the record.
