# CVE-2020-35901: Use-after-free in actix-http

> A use-after-free vulnerability in the actix-http crate allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v3j6-xf77-8r9c, RUSTSEC-2020-0048

## What is CVE-2020-35901?

CVE-2020-35901 is a high-severity use after free vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the actix-http crate before 2.0.0-alpha.1 for Rust. There is a use-after-free in BodyStream.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2020-35901?

3 open source packages ship an affected version, including actix-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actix-http` | crates.io | All versions | 2.0.0 |
| `actix-http` | crates.io | All versions | 2.0.0 |
| `actix-http` | crates.io | From 0.0.0-0 | 2.0.0-alpha.1 |

Products: Actix Actix-Http.

## How do I fix CVE-2020-35901?

Upgrade actix-http to a fixed version for your release line: 2.0.0 or 2.0.0-alpha.1.

## Is CVE-2020-35901 being exploited?

There is no known exploitation of CVE-2020-35901 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-38512](https://insights.sbomify.com/CVE-2021-38512/): HTTP Request Smuggling in actix-http (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35901 and fix it if it is affected.

What it is: CVE-2020-35901 is a high-severity use after free vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35901 in the wild and no public exploit code.

Affected packages and fixed versions:
- actix-http (crates.io): affected all versions; fixed in 2.0.0
- actix-http (crates.io): affected all versions; fixed in 2.0.0
- actix-http (crates.io): affected from 0.0.0-0; fixed in 2.0.0-alpha.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35901/ (Markdown: https://insights.sbomify.com/CVE-2020-35901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35901
- OSV: https://osv.dev/vulnerability/CVE-2020-35901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35901/
Summaries are generated and may contain mistakes; the official description above is the record.
