# CVE-2020-35905: MutexGuard::map can cause a data race in safe code

> A data race in the futures-util crate allows unsafe memory access in safe code, potentially leading to undefined behavior or crashes.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rh4w-94hh-9943, RUSTSEC-2020-0059

## What is CVE-2020-35905?

CVE-2020-35905 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the futures-util crate before 0.3.7 for Rust. MutexGuard::map can cause a data race for certain closure situations (in safe code).

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2020-35905?

3 open source packages ship an affected version, including futures-util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `futures-util` | crates.io | From 0.3.2 | 0.3.7 |
| `futures-util` | crates.io | From 0.3.2 | 0.3.7 |
| `futures-util` | crates.io | From 0.3.2 | 0.3.7 |

Products: Rust-Lang Future-Utils.

## How do I fix CVE-2020-35905?

Upgrade futures-util to 0.3.7 or later.

## Is CVE-2020-35905 being exploited?

There is no known exploitation of CVE-2020-35905 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-35908](https://insights.sbomify.com/CVE-2020-35908/): Improper `Sync` implementation on `FuturesUnordered` in futures-utils can cause data corruption (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35905 and fix it if it is affected.

What it is: CVE-2020-35905 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35905 in the wild and no public exploit code.

Affected packages and fixed versions:
- futures-util (crates.io): affected from 0.3.2; fixed in 0.3.7
- futures-util (crates.io): affected from 0.3.2; fixed in 0.3.7
- futures-util (crates.io): affected from 0.3.2; fixed in 0.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35905/ (Markdown: https://insights.sbomify.com/CVE-2020-35905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35905
- OSV: https://osv.dev/vulnerability/CVE-2020-35905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35905/
Summaries are generated and may contain mistakes; the official description above is the record.
