# CVE-2020-35906: futures_task::waker may cause a use-after-free if used on a type that isn't 'static

> A use-after-free vulnerability in the futures-task crate allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-r93v-9p5q-vhpf, RUSTSEC-2020-0060, UBUNTU-CVE-2020-35906

## What is CVE-2020-35906?

CVE-2020-35906 is a high-severity use after free vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the futures-task crate before 0.3.6 for Rust. futures_task::waker may cause a use-after-free in a non-static type situation.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2020-35906?

3 open source packages ship an affected version, including futures-task. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `futures-task` | crates.io | From 0.2.1 | 0.3.6 |
| `futures-task` | crates.io | From 0.2.1 | 0.3.6 |
| `futures-task` | crates.io | From 0.2.2-0 | 0.3.6 |

Products: Rust-Lang Futures-Task.

## How do I fix CVE-2020-35906?

Upgrade futures-task to 0.3.6 or later.

## Is CVE-2020-35906 being exploited?

There is no known exploitation of CVE-2020-35906 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-35907](https://insights.sbomify.com/CVE-2020-35907/): futures_task::noop_waker_ref can segfault due to dereferencing a NULL pointer (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35906 and fix it if it is affected.

What it is: CVE-2020-35906 is a high-severity use after free vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35906 in the wild and no public exploit code.

Affected packages and fixed versions:
- futures-task (crates.io): affected from 0.2.1; fixed in 0.3.6
- futures-task (crates.io): affected from 0.2.1; fixed in 0.3.6
- futures-task (crates.io): affected from 0.2.2-0; fixed in 0.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35906/ (Markdown: https://insights.sbomify.com/CVE-2020-35906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35906
- OSV: https://osv.dev/vulnerability/CVE-2020-35906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35906/
Summaries are generated and may contain mistakes; the official description above is the record.
