{"answers":{"affected":"3 open source packages ship an affected version, including futures-intrusive. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-35915 in the wild and no public exploit code.","fix":"Upgrade futures-intrusive to 0.4.0 or later.","what":"CVE-2020-35915 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-35915 and fix it if it is affected.\n\nWhat it is: CVE-2020-35915 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-35915 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- futures-intrusive (crates.io): affected all versions; fixed in 0.4.0\n- futures-intrusive (crates.io): affected all versions; fixed in 0.4.0\n- futures-intrusive (crates.io): affected from 0.0.0-0; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-35915/ (Markdown: https://insights.sbomify.com/CVE-2020-35915/index.md)","id":"CVE-2020-35915","markdown":"https://insights.sbomify.com/CVE-2020-35915/index.md","name":"CVE-2020-35915","record":{"aliases":["GHSA-4hjg-cx88-g9f9","RUSTSEC-2020-0072"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust futures-intrusive crate","requires_auth":"low_privilege","summary":"Attackers can exploit cross-thread data races in GenericMutexGuard to read or modify non-Sync data, affecting Rust applications using the futures-intrusive crate.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"futures-intrusive","vendor":"futures-intrusive_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"An issue was discovered in the futures-intrusive crate before 0.4.0 for Rust. GenericMutexGuard allows cross-thread data races of non-Sync types.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Data races in futures-intrusive","id":"CVE-2020-35915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"race_condition","year":"2020"},"n_packages":3,"n_references":1,"next":{"headline":"Mutable reference with immutable provenance in image","id":"CVE-2020-35916"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"futures-intrusive","purl":null,"source":"GHSA-4hjg-cx88-g9f9"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"futures-intrusive","purl":"pkg:cargo/futures-intrusive","source":"GHSA-4hjg-cx88-g9f9"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"futures-intrusive","purl":"pkg:cargo/futures-intrusive","source":"RUSTSEC-2020-0072"}],"prev":{"headline":"An issue was discovered in the lock_api crate before 0.4.2 for Rust.","id":"CVE-2020-35914"},"products":["n/a"],"published":"2020-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can exploit cross-thread data races in GenericMutexGuard to read or modify non-Sync data, affecting Rust applications using the futures-intrusive crate.","url":"https://insights.sbomify.com/CVE-2020-35915/"}