# CVE-2020-35915: Data races in futures-intrusive

> Attackers can exploit cross-thread data races in GenericMutexGuard to read or modify non-Sync data, affecting Rust applications using the futures-intrusive crate.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4hjg-cx88-g9f9, RUSTSEC-2020-0072

## What is CVE-2020-35915?

CVE-2020-35915 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the futures-intrusive crate before 0.4.0 for Rust. GenericMutexGuard allows cross-thread data races of non-Sync types.

## Which versions are affected by CVE-2020-35915?

3 open source packages ship an affected version, including futures-intrusive. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `futures-intrusive` | crates.io | All versions | 0.4.0 |
| `futures-intrusive` | crates.io | All versions | 0.4.0 |
| `futures-intrusive` | crates.io | From 0.0.0-0 | 0.4.0 |

Products: Futures-Intrusive Project Futures-Intrusive.

## How do I fix CVE-2020-35915?

Upgrade futures-intrusive to 0.4.0 or later.

## Is CVE-2020-35915 being exploited?

There is no known exploitation of CVE-2020-35915 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35915 and fix it if it is affected.

What it is: CVE-2020-35915 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35915 in the wild and no public exploit code.

Affected packages and fixed versions:
- futures-intrusive (crates.io): affected all versions; fixed in 0.4.0
- futures-intrusive (crates.io): affected all versions; fixed in 0.4.0
- futures-intrusive (crates.io): affected from 0.0.0-0; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35915/ (Markdown: https://insights.sbomify.com/CVE-2020-35915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35915
- OSV: https://osv.dev/vulnerability/CVE-2020-35915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35915/
Summaries are generated and may contain mistakes; the official description above is the record.
