# CVE-2020-35916: Mutable reference with immutable provenance in image


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-35916, GHSA-9wgh-vjj7-7433, RUSTSEC-2020-0073, UBUNTU-CVE-2020-35916

## What is CVE-2020-35916?

CVE-2020-35916 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. 

### Official description

An issue was discovered in the image crate before 0.23.12 for Rust. A Mutable reference has immutable provenance. (In the case of LLVM, the IR may be always correct.)

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-35916?

3 open source packages ship an affected version, including image. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `image` | crates.io | All versions | 0.23.12 |
| `image` | crates.io | All versions | 0.23.12 |
| `image` | crates.io | From 0.0.0-0 | 0.23.12 |

Products: Image-Rs Image.

## How do I fix CVE-2020-35916?

Upgrade image to 0.23.12 or later.

## Is CVE-2020-35916 being exploited?

There is no known exploitation of CVE-2020-35916 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-16138](https://insights.sbomify.com/CVE-2019-16138/): Use after free in image (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35916 and fix it if it is affected.

What it is: CVE-2020-35916 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. 
Exploitation: There is no known exploitation of CVE-2020-35916 in the wild and no public exploit code.

Affected packages and fixed versions:
- image (crates.io): affected all versions; fixed in 0.23.12
- image (crates.io): affected all versions; fixed in 0.23.12
- image (crates.io): affected from 0.0.0-0; fixed in 0.23.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35916/ (Markdown: https://insights.sbomify.com/CVE-2020-35916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35916
- OSV: https://osv.dev/vulnerability/CVE-2020-35916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35916/
Summaries are generated and may contain mistakes; the official description above is the record.
