# CVE-2020-35917: Reference counting error in pyo3

> A use-after-free vulnerability in the pyo3 Rust crate allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2vx6-fcw6-hpr6, RUSTSEC-2020-0074

## What is CVE-2020-35917?

CVE-2020-35917 is a medium-severity use after free vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the pyo3 crate before 0.12.4 for Rust. There is a reference-counting error and use-after-free in From<Py<T>>.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2020-35917?

3 open source packages ship an affected version, including pyo3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyo3` | crates.io | From 0.12.0 | 0.12.4 |
| `pyo3` | crates.io | From 0.12.0 | 0.12.4 |
| `pyo3` | crates.io | From 0.12.0 | 0.12.4 |

Products: Pyo3 Project Pyo3.

## How do I fix CVE-2020-35917?

Upgrade pyo3 to 0.12.4 or later.

## Is CVE-2020-35917 being exploited?

There is no known exploitation of CVE-2020-35917 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35917 and fix it if it is affected.

What it is: CVE-2020-35917 is a medium-severity use after free vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35917 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyo3 (crates.io): affected from 0.12.0; fixed in 0.12.4
- pyo3 (crates.io): affected from 0.12.0; fixed in 0.12.4
- pyo3 (crates.io): affected from 0.12.0; fixed in 0.12.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35917/ (Markdown: https://insights.sbomify.com/CVE-2020-35917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35917
- OSV: https://osv.dev/vulnerability/CVE-2020-35917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35917/
Summaries are generated and may contain mistakes; the official description above is the record.
